Using an outdated version of WordPress core, plugins or themes isn’t ideal. PHP is no different.

While WordPress technically works with PHP 5.6 and above, you’re sacrificing performance and compatibility, plus you’re open to security vulnerabilities by using older PHP versions. You should always aim to use the latest version of PHP.

In this post, you’ll learn everything you need to check what version of PHP you are running and how to update your PHP to the recommended version for WordPress.

What is PHP

Read the entire post on WPMU Dev's site